NextGen -Warnhinweis bei der Verwendung von Alben

Nachtrag vom 15.2.13

Nach Installation des NextGen Update Version 1.9.11 ist der Fehler behoben

 

Wird eine PHP Version 5.4 bzw. größer verwendet so gibt es zur Zeit Probleme mit NextGen. Auf den Seiten wo die Albumfunktion zum Einsatz kommt erscheint folgender Warnhinweis:

Warning:  Creating default object from empty value in /homepages/…./wp-content/plugins/nextgen-gallery/nggfunctions.php on line 554

Ausführlich wird das Thema hier… diskutiert.

Die aktuelle NextGen Version 1.9.10 liefert leider noch keine Abhilfe.

Kurzfristig kann die Warnung unterdrückt werden indem man in die nggfunctions.php eingreift. Dazu wird ein kleiner Codeabschnitt (Zeile 553 bis 556) ausmaskiert und schon ist man den Hinweis los.

	// No images found, set counter to 0
    //    if (!isset($galleries[$key]->counter)){
    //        $galleries[$key]->counter = 0;
    //        $galleries[$key]->previewurl = '';
    //    }

Beim nächsten Update ist der Fehler hoffentlich behoben! Mich hat er leider einige Stunden beschäfftigt

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*